Home > CentOS & RHEL 6 > CentOS 6 libevent multilib issues

CentOS 6 libevent multilib issues

Trying to run a `yum update` on a CentOS 6.4 box was giving multilib errors and failing horribly (this is after sorting out the epel repo ssl problem). After much faffing I finally resolved1 it.

First, the error:

[[email protected]~]# yum update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
epel/metalink | 21 kB 00:00
* epel: anorien.csc.warwick.ac.uk
* remi: remi.check-update.co.uk
* rpmforge: ftp.nluug.nl
epel | 4.4 kB 00:00
epel/primary_db | 6.6 MB 00:04
Setting up Update Process
Resolving Dependencies
–> Running transaction check

<-- Packages snipped for berevity, full output is at the bottom of the post -->

–> Finished Dependency Resolution
–> Running transaction check
—> Package kernel.x86_64 0:2.6.32-279.14.1.el6 will be erased
–> Finished Dependency Resolution
Error: Multilib version problems found. This often means that the root
cause is something else and multilib version checking is just
pointing out that there is a problem. Eg.:

1. You have an upgrade for libevent-devel which is missing some
dependency that another package requires. Yum is trying to
solve this by installing an older version of libevent-devel of the
different architecture. If you exclude the bad architecture
yum will tell you what the root cause is (which package
requires what). You can try redoing the upgrade with
–exclude libevent-devel.otherarch … this should give you an error
message showing the root cause of the problem.

2. You have multiple architectures of libevent-devel installed, but
yum can only see an upgrade for one of those arcitectures.
If you don’t want/need both architectures anymore then you
can remove the one with the missing update and everything
will work.

3. You have duplicate versions of libevent-devel installed already.
You can use “yum check” to get yum show these errors.

…you can also use –setopt=protected_multilib=false to remove
this checking, however this is almost never the correct thing to
do as something else is very likely to go wrong (often causing
much more problems).

Protected multilib versions: libevent-devel-2.0.19-1.rhel6.x86_64 != libevent-devel-1.4.13-4.el6.i686
Error: Protected multilib versions: libevent-1.4.13-4.el6.i686 != libevent-2.0.19-1.rhel6.x86_64
You could try using –skip-broken to work around the problem
You could try running: rpm -Va –nofiles –nodigest
[[email protected]~]#

damn that libevent. This probably isn’t helped by the fact we’ve got a handful of 3rd party repos in use.
The PostgreSQL repo actually includes compat-libevent14 which seems to fulfil our needs, so here are the steps to sort everything out:

[[email protected]~]# yum remove libevent libevent-devel
Removing:
libevent x86_64 1.4.13-4.el6 @base 227 k
libevent-devel x86_64 1.4.13-4.el6 @base 421 k
Removing for dependencies:
gearmand x86_64 0.14-3.el6.2 @epel 113 k
libevent-doc noarch 1.4.13-4.el6 @base 924 k
libevent-headers noarch 1.4.13-4.el6 @base 96 k
libmemcached x86_64 1.0.16-1.el6.remi @remi 628 k
libmemcached-devel x86_64 1.0.16-1.el6.remi @remi 593 k
memcached x86_64 1.4.15-2.el6.remi @remi 169 k
tmux x86_64 1.6-1.el6.rf @rpmforge 556 k

Transaction Summary
=============================================================================================================================
Remove 9 Package(s)

As you can see, on my system this also removes a handful of packages that depend on the libs (don’t worry, we’ll reinstall them in a moment).

We then install the libevent-compat packages:

[[email protected]~]# yum install compat-libevent14 compat-libevent14-devel

and we can then re-install the packages that were removed above

[[email protected]~]# yum install gearmand libmemcached libmemcached-devel memcached tmux

and now we can continue with the rest of our updates

[[email protected]~]# yum update

Done.

# full yum update output when failing (from top of the post):

[[email protected]~]# yum update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
epel/metalink | 21 kB 00:00
* epel: anorien.csc.warwick.ac.uk
* remi: remi.check-update.co.uk
* rpmforge: ftp.nluug.nl
epel | 4.4 kB 00:00
epel/primary_db | 6.6 MB 00:04
Setting up Update Process
Resolving Dependencies
–> Running transaction check
—> Package ORBit2.x86_64 0:2.14.17-3.2.el6_3 will be updated
—> Package ORBit2.x86_64 0:2.14.17-5.el6 will be an update
—> Package atk.x86_64 0:1.28.0-2.el6 will be updated
—> Package atk.x86_64 0:1.30.0-1.el6 will be an update
—> Package audit.x86_64 0:2.2-2.el6 will be updated
—> Package audit.x86_64 0:2.3.7-5.el6 will be an update
—> Package audit-libs.x86_64 0:2.2-2.el6 will be updated
—> Package audit-libs.x86_64 0:2.3.7-5.el6 will be an update
—> Package authconfig.x86_64 0:6.1.12-13.el6 will be updated
—> Package authconfig.x86_64 0:6.1.12-19.el6 will be an update
—> Package avahi-libs.x86_64 0:0.6.25-12.el6 will be updated
—> Package avahi-libs.x86_64 0:0.6.25-15.el6 will be an update
—> Package bash.x86_64 0:4.1.2-15.el6_5.2 will be updated
—> Package bash.x86_64 0:4.1.2-29.el6 will be an update
—> Package bfa-firmware.noarch 0:3.0.3.1-1.el6 will be updated
—> Package bfa-firmware.noarch 0:3.2.23.0-2.el6 will be an update
—> Package bind-libs.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
—> Package bind-libs.x86_64 32:9.8.2-0.30.rc1.el6_6.3 will be an update
—> Package bind-utils.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
—> Package bind-utils.x86_64 32:9.8.2-0.30.rc1.el6_6.3 will be an update
—> Package binutils.x86_64 0:2.20.51.0.2-5.36.el6 will be updated
—> Package binutils.x86_64 0:2.20.51.0.2-5.42.el6 will be an update
—> Package boost.x86_64 0:1.41.0-17.el6_4 will be updated
—> Package boost.x86_64 0:1.41.0-25.el6.centos will be an update
—> Package boost-date-time.x86_64 0:1.41.0-17.el6_4 will be updated
—> Package boost-date-time.x86_64 0:1.41.0-25.el6.centos will be an update
—> Package boost-devel.x86_64 0:1.41.0-17.el6_4 will be updated
—> Package boost-devel.x86_64 0:1.41.0-25.el6.centos will be an update
–> Processing Dependency: libboost_math_tr1l.so.5()(64bit) for package: boost-devel-1.41.0-25.el6.centos.x86_64
–> Processing Dependency: libboost_math_tr1l-mt.so.5()(64bit) for package: boost-devel-1.41.0-25.el6.centos.x86_64
–> Processing Dependency: libboost_math_tr1f.so.5()(64bit) for package: boost-devel-1.41.0-25.el6.centos.x86_64
–> Processing Dependency: libboost_math_tr1f-mt.so.5()(64bit) for package: boost-devel-1.41.0-25.el6.centos.x86_64
–> Processing Dependency: libboost_math_tr1.so.5()(64bit) for package: boost-devel-1.41.0-25.el6.centos.x86_64
–> Processing Dependency: libboost_math_tr1-mt.so.5()(64bit) for package: boost-devel-1.41.0-25.el6.centos.x86_64
–> Processing Dependency: libboost_math_c99l.so.5()(64bit) for package: boost-devel-1.41.0-25.el6.centos.x86_64
–> Processing Dependency: libboost_math_c99l-mt.so.5()(64bit) for package: boost-devel-1.41.0-25.el6.centos.x86_64
–> Processing Dependency: libboost_math_c99f.so.5()(64bit) for package: boost-devel-1.41.0-25.el6.centos.x86_64
–> Processing Dependency: libboost_math_c99f-mt.so.5()(64bit) for package: boost-devel-1.41.0-25.el6.centos.x86_64
–> Processing Dependency: libboost_math_c99.so.5()(64bit) for package: boost-devel-1.41.0-25.el6.centos.x86_64
–> Processing Dependency: libboost_math_c99-mt.so.5()(64bit) for package: boost-devel-1.41.0-25.el6.centos.x86_64
—> Package boost-filesystem.x86_64 0:1.41.0-17.el6_4 will be updated
—> Package boost-filesystem.x86_64 0:1.41.0-25.el6.centos will be an update
—> Package boost-graph.x86_64 0:1.41.0-17.el6_4 will be updated
—> Package boost-graph.x86_64 0:1.41.0-25.el6.centos will be an update
—> Package boost-iostreams.x86_64 0:1.41.0-17.el6_4 will be updated
—> Package boost-iostreams.x86_64 0:1.41.0-25.el6.centos will be an update
—> Package boost-program-options.x86_64 0:1.41.0-17.el6_4 will be updated
—> Package boost-program-options.x86_64 0:1.41.0-25.el6.centos will be an update
—> Package boost-python.x86_64 0:1.41.0-17.el6_4 will be updated
—> Package boost-python.x86_64 0:1.41.0-25.el6.centos will be an update
—> Package boost-regex.x86_64 0:1.41.0-17.el6_4 will be updated
—> Package boost-regex.x86_64 0:1.41.0-25.el6.centos will be an update
—> Package boost-serialization.x86_64 0:1.41.0-17.el6_4 will be updated
—> Package boost-serialization.x86_64 0:1.41.0-25.el6.centos will be an update
—> Package boost-signals.x86_64 0:1.41.0-17.el6_4 will be updated
—> Package boost-signals.x86_64 0:1.41.0-25.el6.centos will be an update
—> Package boost-system.x86_64 0:1.41.0-17.el6_4 will be updated
—> Package boost-system.x86_64 0:1.41.0-25.el6.centos will be an update
—> Package boost-test.x86_64 0:1.41.0-17.el6_4 will be updated
—> Package boost-test.x86_64 0:1.41.0-25.el6.centos will be an update
—> Package boost-thread.x86_64 0:1.41.0-17.el6_4 will be updated
—> Package boost-thread.x86_64 0:1.41.0-25.el6.centos will be an update
—> Package boost-wave.x86_64 0:1.41.0-17.el6_4 will be updated
—> Package boost-wave.x86_64 0:1.41.0-25.el6.centos will be an update
—> Package cairo.x86_64 0:1.8.8-3.1.el6 will be updated
—> Package cairo.x86_64 0:1.8.8-6.el6_6 will be an update
—> Package centos-indexhtml.noarch 0:6-1.el6.centos will be updated
—> Package centos-indexhtml.noarch 0:6-2.el6.centos will be an update
—> Package centos-release.x86_64 0:6-4.el6.centos.10 will be updated
—> Package centos-release.x86_64 0:6-6.el6.centos.12.2 will be an update
—> Package chkconfig.x86_64 0:1.3.49.3-2.el6 will be updated
—> Package chkconfig.x86_64 0:1.3.49.3-2.el6_4.1 will be an update
—> Package chkrootkit.x86_64 0:0.49-2.el6 will be updated
—> Package chkrootkit.x86_64 0:0.49-9.el6 will be an update
—> Package coreutils.x86_64 0:8.4-19.el6_4.2 will be updated
—> Package coreutils.x86_64 0:8.4-37.el6 will be an update
—> Package coreutils-libs.x86_64 0:8.4-19.el6_4.2 will be updated
—> Package coreutils-libs.x86_64 0:8.4-37.el6 will be an update
—> Package cpio.x86_64 0:2.10-11.el6_3 will be updated
—> Package cpio.x86_64 0:2.10-12.el6_5 will be an update
—> Package cpp.x86_64 0:4.4.7-3.el6 will be updated
—> Package cpp.x86_64 0:4.4.7-11.el6 will be an update
—> Package cronie.x86_64 0:1.4.4-7.el6 will be updated
—> Package cronie.x86_64 0:1.4.4-12.el6 will be an update
—> Package cronie-anacron.x86_64 0:1.4.4-7.el6 will be updated
—> Package cronie-anacron.x86_64 0:1.4.4-12.el6 will be an update
—> Package cups-libs.x86_64 1:1.4.2-50.el6_4.4 will be updated
—> Package cups-libs.x86_64 1:1.4.2-67.el6_6.1 will be an update
—> Package curl.x86_64 0:7.19.7-37.el6_4 will be updated
—> Package curl.x86_64 0:7.19.7-40.el6_6.4 will be an update
—> Package cvs.x86_64 0:1.11.23-15.el6 will be updated
—> Package cvs.x86_64 0:1.11.23-16.el6 will be an update
—> Package cyrus-sasl.x86_64 0:2.1.23-13.el6_3.1 will be updated
—> Package cyrus-sasl.x86_64 0:2.1.23-15.el6_6.2 will be an update
—> Package cyrus-sasl-devel.x86_64 0:2.1.23-13.el6_3.1 will be updated
—> Package cyrus-sasl-devel.x86_64 0:2.1.23-15.el6_6.2 will be an update
—> Package cyrus-sasl-lib.x86_64 0:2.1.23-13.el6_3.1 will be updated
—> Package cyrus-sasl-lib.x86_64 0:2.1.23-15.el6_6.2 will be an update
—> Package db4.x86_64 0:4.7.25-17.el6 will be updated
—> Package db4.x86_64 0:4.7.25-19.el6_6 will be an update
—> Package db4-utils.x86_64 0:4.7.25-17.el6 will be updated
—> Package db4-utils.x86_64 0:4.7.25-19.el6_6 will be an update
—> Package dbus.x86_64 1:1.2.24-7.el6_3 will be updated
—> Package dbus.x86_64 1:1.2.24-8.el6_6 will be an update
—> Package dbus-libs.x86_64 1:1.2.24-7.el6_3 will be updated
—> Package dbus-libs.x86_64 1:1.2.24-8.el6_6 will be an update
—> Package device-mapper.x86_64 0:1.02.77-9.el6 will be updated
—> Package device-mapper.x86_64 0:1.02.90-2.el6_6.3 will be an update
—> Package device-mapper-event.x86_64 0:1.02.77-9.el6 will be updated
—> Package device-mapper-event.x86_64 0:1.02.90-2.el6_6.3 will be an update
—> Package device-mapper-event-libs.x86_64 0:1.02.77-9.el6 will be updated
—> Package device-mapper-event-libs.x86_64 0:1.02.90-2.el6_6.3 will be an update
—> Package device-mapper-libs.x86_64 0:1.02.77-9.el6 will be updated
—> Package device-mapper-libs.x86_64 0:1.02.90-2.el6_6.3 will be an update
—> Package device-mapper-persistent-data.x86_64 0:0.1.4-1.el6 will be updated
—> Package device-mapper-persistent-data.x86_64 0:0.3.2-1.el6 will be an update
—> Package dhclient.x86_64 12:4.1.1-34.P1.el6.centos will be updated
—> Package dhclient.x86_64 12:4.1.1-43.P1.el6.centos.1 will be an update
—> Package dhcp-common.x86_64 12:4.1.1-34.P1.el6.centos will be updated
—> Package dhcp-common.x86_64 12:4.1.1-43.P1.el6.centos.1 will be an update
—> Package dracut.noarch 0:004-303.el6 will be updated
—> Package dracut.noarch 0:004-356.el6_6.2 will be an update
—> Package dracut-kernel.noarch 0:004-303.el6 will be updated
—> Package dracut-kernel.noarch 0:004-356.el6_6.2 will be an update
—> Package e2fsprogs.x86_64 0:1.41.12-14.el6_4.2 will be updated
—> Package e2fsprogs.x86_64 0:1.41.12-21.el6 will be an update
—> Package e2fsprogs-libs.x86_64 0:1.41.12-14.el6_4.2 will be updated
—> Package e2fsprogs-libs.x86_64 0:1.41.12-21.el6 will be an update
—> Package efibootmgr.x86_64 0:0.5.4-10.el6 will be updated
—> Package efibootmgr.x86_64 0:0.5.4-12.el6 will be an update
—> Package elfutils.x86_64 0:0.152-1.el6 will be updated
—> Package elfutils.x86_64 0:0.158-3.2.el6 will be an update
—> Package elfutils-libelf.x86_64 0:0.152-1.el6 will be updated
—> Package elfutils-libelf.x86_64 0:0.158-3.2.el6 will be an update
—> Package elfutils-libs.x86_64 0:0.152-1.el6 will be updated
—> Package elfutils-libs.x86_64 0:0.158-3.2.el6 will be an update
—> Package ethtool.x86_64 2:3.5-1.el6 will be updated
—> Package ethtool.x86_64 2:3.5-5.el6 will be an update
—> Package file.x86_64 0:5.04-15.el6 will be updated
—> Package file.x86_64 0:5.04-21.el6 will be an update
—> Package file-libs.x86_64 0:5.04-15.el6 will be updated
—> Package file-libs.x86_64 0:5.04-21.el6 will be an update
—> Package flex.x86_64 0:2.5.35-8.el6 will be updated
—> Package flex.x86_64 0:2.5.35-9.el6 will be an update
—> Package fontconfig.x86_64 0:2.8.0-3.el6 will be updated
—> Package fontconfig.x86_64 0:2.8.0-5.el6 will be an update
—> Package freetype.x86_64 0:2.3.11-14.el6_3.1 will be updated
—> Package freetype.x86_64 0:2.3.11-15.el6_6.1 will be an update
—> Package gcc.x86_64 0:4.4.7-3.el6 will be updated
—> Package gcc.x86_64 0:4.4.7-11.el6 will be an update
—> Package gcc-c++.x86_64 0:4.4.7-3.el6 will be updated
—> Package gcc-c++.x86_64 0:4.4.7-11.el6 will be an update
—> Package gcc-gfortran.x86_64 0:4.4.7-3.el6 will be updated
—> Package gcc-gfortran.x86_64 0:4.4.7-11.el6 will be an update
—> Package gdb.x86_64 0:7.2-60.el6_4.1 will be updated
—> Package gdb.x86_64 0:7.2-75.el6 will be an update
—> Package gearmand.x86_64 0:0.14-3.el6.2 will be updated
—> Package gearmand.x86_64 0:1.1.8-2.el6 will be an update
–> Processing Dependency: libtokyocabinet.so.8()(64bit) for package: gearmand-1.1.8-2.el6.x86_64
—> Package gettext.x86_64 0:0.17-16.el6 will be updated
—> Package gettext.x86_64 0:0.17-18.el6 will be an update
—> Package gettext-devel.x86_64 0:0.17-16.el6 will be updated
—> Package gettext-devel.x86_64 0:0.17-18.el6 will be an update
—> Package gettext-libs.x86_64 0:0.17-16.el6 will be updated
—> Package gettext-libs.x86_64 0:0.17-18.el6 will be an update
—> Package glib2.x86_64 0:2.22.5-7.el6 will be updated
—> Package glib2.x86_64 0:2.28.8-4.el6 will be an update
–> Processing Dependency: shared-mime-info for package: glib2-2.28.8-4.el6.x86_64
—> Package glibc.x86_64 0:2.12-1.107.el6_4.2 will be updated
—> Package glibc.x86_64 0:2.12-1.149.el6_6.9 will be an update
—> Package glibc-common.x86_64 0:2.12-1.107.el6_4.2 will be updated
—> Package glibc-common.x86_64 0:2.12-1.149.el6_6.9 will be an update
—> Package glibc-devel.x86_64 0:2.12-1.107.el6_4.2 will be updated
—> Package glibc-devel.x86_64 0:2.12-1.149.el6_6.9 will be an update
—> Package glibc-headers.x86_64 0:2.12-1.107.el6_4.2 will be updated
—> Package glibc-headers.x86_64 0:2.12-1.149.el6_6.9 will be an update
—> Package gnupg2.x86_64 0:2.0.14-4.el6 will be updated
—> Package gnupg2.x86_64 0:2.0.14-8.el6 will be an update
—> Package gnutls.x86_64 0:2.8.5-10.el6_4.2 will be updated
—> Package gnutls.x86_64 0:2.8.5-14.el6_5 will be an update
—> Package grep.x86_64 0:2.6.3-3.el6 will be updated
—> Package grep.x86_64 0:2.6.3-6.el6 will be an update
—> Package grub.x86_64 1:0.97-81.el6 will be updated
—> Package grub.x86_64 1:0.97-93.el6 will be an update
—> Package grubby.x86_64 0:7.0.15-3.el6 will be updated
—> Package grubby.x86_64 0:7.0.15-7.el6 will be an update
—> Package gtk2.x86_64 0:2.18.9-12.el6 will be updated
–> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: gtk2-2.24.23-6.el6.x86_64
–> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: xulrunner-last-22.0-1.el6.remi.x86_64
–> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: pygtk2-2.16.0-3.el6.x86_64
–> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: libglade2-2.6.4-3.1.el6.x86_64
–> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: pygtk2-libglade-2.16.0-3.el6.x86_64
–> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: libgcj-4.4.7-11.el6.x86_64
—> Package gtk2.x86_64 0:2.24.23-6.el6 will be an update
—> Package gzip.x86_64 0:1.3.12-19.el6_4 will be updated
—> Package gzip.x86_64 0:1.3.12-22.el6 will be an update
—> Package htop.x86_64 0:1.0.2-1.el6.rf will be updated
—> Package htop.x86_64 0:1.0.3-1.el6.rf will be an update
—> Package httpd.x86_64 0:2.2.15-28.el6.centos will be updated
—> Package httpd.x86_64 0:2.2.15-39.el6.centos will be an update
—> Package httpd-tools.x86_64 0:2.2.15-28.el6.centos will be updated
—> Package httpd-tools.x86_64 0:2.2.15-39.el6.centos will be an update
—> Package hwdata.noarch 0:0.233-7.9.el6 will be updated
—> Package hwdata.noarch 0:0.233-11.1.el6 will be an update
—> Package initscripts.x86_64 0:9.03.38-1.el6.centos.1 will be updated
—> Package initscripts.x86_64 0:9.03.46-1.el6.centos.1 will be an update
—> Package iproute.x86_64 0:2.6.32-23.el6 will be updated
—> Package iproute.x86_64 0:2.6.32-33.el6_6 will be an update
—> Package iptables.x86_64 0:1.4.7-9.el6 will be updated
—> Package iptables.x86_64 0:1.4.7-14.el6 will be an update
—> Package iptables-ipv6.x86_64 0:1.4.7-9.el6 will be updated
—> Package iptables-ipv6.x86_64 0:1.4.7-14.el6 will be an update
—> Package iputils.x86_64 0:20071127-17.el6_4 will be updated
—> Package iputils.x86_64 0:20071127-17.el6_4.2 will be an update
—> Package jasper-libs.x86_64 0:1.900.1-15.el6_1.1 will be updated
—> Package jasper-libs.x86_64 0:1.900.1-16.el6_6.3 will be an update
—> Package kernel.x86_64 0:2.6.32-504.23.4.el6 will be installed
—> Package kernel-devel.x86_64 0:2.6.32-504.23.4.el6 will be installed
—> Package kernel-firmware.noarch 0:2.6.32-358.14.1.el6 will be updated
—> Package kernel-firmware.noarch 0:2.6.32-504.23.4.el6 will be an update
—> Package kernel-headers.x86_64 0:2.6.32-358.14.1.el6 will be updated
—> Package kernel-headers.x86_64 0:2.6.32-504.23.4.el6 will be an update
—> Package keyutils-libs.x86_64 0:1.4-4.el6 will be updated
—> Package keyutils-libs.x86_64 0:1.4-5.el6 will be an update
—> Package keyutils-libs-devel.x86_64 0:1.4-4.el6 will be updated
—> Package keyutils-libs-devel.x86_64 0:1.4-5.el6 will be an update
—> Package krb5-devel.x86_64 0:1.10.3-10.el6_4.4 will be updated
—> Package krb5-devel.x86_64 0:1.10.3-37.el6_6 will be an update
—> Package krb5-libs.x86_64 0:1.10.3-10.el6_4.4 will be updated
—> Package krb5-libs.x86_64 0:1.10.3-37.el6_6 will be an update
—> Package less.x86_64 0:436-10.el6 will be updated
—> Package less.x86_64 0:436-13.el6 will be an update
—> Package libX11.x86_64 0:1.5.0-4.el6 will be updated
—> Package libX11.x86_64 0:1.6.0-2.2.el6 will be an update
—> Package libX11-common.noarch 0:1.5.0-4.el6 will be updated
—> Package libX11-common.noarch 0:1.6.0-2.2.el6 will be an update
—> Package libXcursor.x86_64 0:1.1.13-2.el6 will be updated
—> Package libXcursor.x86_64 0:1.1.14-2.1.el6 will be an update
—> Package libXext.x86_64 0:1.3.1-2.el6 will be updated
—> Package libXext.x86_64 0:1.3.2-2.1.el6 will be an update
—> Package libXfixes.x86_64 0:5.0-3.el6 will be updated
—> Package libXfixes.x86_64 0:5.0.1-2.1.el6 will be an update
—> Package libXi.x86_64 0:1.6.1-3.el6 will be updated
—> Package libXi.x86_64 0:1.7.2-2.2.el6 will be an update
—> Package libXinerama.x86_64 0:1.1.2-2.el6 will be updated
—> Package libXinerama.x86_64 0:1.1.3-2.1.el6 will be an update
—> Package libXrandr.x86_64 0:1.4.0-1.el6 will be updated
—> Package libXrandr.x86_64 0:1.4.1-2.1.el6 will be an update
—> Package libXrender.x86_64 0:0.9.7-2.el6 will be updated
—> Package libXrender.x86_64 0:0.9.8-2.1.el6 will be an update
—> Package libXt.x86_64 0:1.1.3-1.el6 will be updated
—> Package libXt.x86_64 0:1.1.4-6.1.el6 will be an update
—> Package libXtst.x86_64 0:1.2.1-2.el6 will be updated
—> Package libXtst.x86_64 0:1.2.2-2.1.el6 will be an update
—> Package libblkid.x86_64 0:2.17.2-12.9.el6_4.3 will be updated
—> Package libblkid.x86_64 0:2.17.2-12.18.el6 will be an update
—> Package libcom_err.x86_64 0:1.41.12-14.el6_4.2 will be updated
—> Package libcom_err.x86_64 0:1.41.12-21.el6 will be an update
—> Package libcom_err-devel.x86_64 0:1.41.12-14.el6_4.2 will be updated
—> Package libcom_err-devel.x86_64 0:1.41.12-21.el6 will be an update
—> Package libcurl.x86_64 0:7.19.7-37.el6_4 will be updated
—> Package libcurl.x86_64 0:7.19.7-40.el6_6.4 will be an update
—> Package libcurl-devel.x86_64 0:7.19.7-37.el6_4 will be updated
—> Package libcurl-devel.x86_64 0:7.19.7-40.el6_6.4 will be an update
—> Package libdrm.x86_64 0:2.4.39-1.el6 will be updated
—> Package libdrm.x86_64 0:2.4.52-4.el6 will be an update
—> Package libevent.x86_64 0:1.4.13-4.el6 will be updated
–> Processing Dependency: libevent-1.4.so.2()(64bit) for package: gearmand-1.1.8-2.el6.x86_64
–> Processing Dependency: libevent-1.4.so.2()(64bit) for package: tmux-1.6-3.el6.x86_64
—> Package libevent.x86_64 0:2.0.19-1.rhel6 will be an update
—> Package libevent-devel.x86_64 0:1.4.13-4.el6 will be updated
–> Processing Dependency: libevent-devel = 1.4.13-4.el6 for package: libevent-headers-1.4.13-4.el6.noarch
–> Processing Dependency: libevent-devel = 1.4.13-4.el6 for package: libevent-doc-1.4.13-4.el6.noarch
—> Package libevent-devel.x86_64 0:2.0.19-1.rhel6 will be an update
—> Package libgcc.x86_64 0:4.4.7-3.el6 will be updated
—> Package libgcc.x86_64 0:4.4.7-11.el6 will be an update
—> Package libgcj.x86_64 0:4.4.7-3.el6 will be updated
—> Package libgcj.x86_64 0:4.4.7-11.el6 will be an update
—> Package libgcrypt.x86_64 0:1.4.5-9.el6_2.2 will be updated
—> Package libgcrypt.x86_64 0:1.4.5-11.el6_4 will be an update
—> Package libgearman.x86_64 0:0.14-3.el6.2 will be updated
—> Package libgearman.x86_64 0:1.1.8-2.el6 will be an update
—> Package libgfortran.x86_64 0:4.4.7-3.el6 will be updated
—> Package libgfortran.x86_64 0:4.4.7-11.el6 will be an update
—> Package libgomp.x86_64 0:4.4.7-3.el6 will be updated
—> Package libgomp.x86_64 0:4.4.7-11.el6 will be an update
—> Package libjpeg-turbo.x86_64 0:1.2.1-1.el6 will be updated
—> Package libjpeg-turbo.x86_64 0:1.2.1-3.el6_5 will be an update
—> Package libmemcached.x86_64 0:1.0.16-1.el6.remi will be updated
—> Package libmemcached.x86_64 0:1.0.17-1.rhel6 will be an update
—> Package libmemcached-devel.x86_64 0:1.0.16-1.el6.remi will be updated
—> Package libmemcached-devel.x86_64 0:1.0.17-1.rhel6 will be an update
—> Package libpciaccess.x86_64 0:0.13.1-2.el6 will be updated
—> Package libpciaccess.x86_64 0:0.13.3-0.1.el6 will be an update
—> Package libproxy.x86_64 0:0.3.0-4.el6_3 will be updated
—> Package libproxy.x86_64 0:0.3.0-10.el6 will be an update
—> Package libproxy-bin.x86_64 0:0.3.0-4.el6_3 will be updated
—> Package libproxy-bin.x86_64 0:0.3.0-10.el6 will be an update
—> Package libproxy-python.x86_64 0:0.3.0-4.el6_3 will be updated
—> Package libproxy-python.x86_64 0:0.3.0-10.el6 will be an update
—> Package libselinux.x86_64 0:2.0.94-5.3.el6_4.1 will be updated
—> Package libselinux.x86_64 0:2.0.94-5.8.el6 will be an update
—> Package libselinux-devel.x86_64 0:2.0.94-5.3.el6_4.1 will be updated
—> Package libselinux-devel.x86_64 0:2.0.94-5.8.el6 will be an update
—> Package libselinux-python.x86_64 0:2.0.94-5.3.el6_4.1 will be updated
—> Package libselinux-python.x86_64 0:2.0.94-5.8.el6 will be an update
—> Package libselinux-utils.x86_64 0:2.0.94-5.3.el6_4.1 will be updated
—> Package libselinux-utils.x86_64 0:2.0.94-5.8.el6 will be an update
—> Package libss.x86_64 0:1.41.12-14.el6_4.2 will be updated
—> Package libss.x86_64 0:1.41.12-21.el6 will be an update
—> Package libssh2.x86_64 0:1.4.2-1.el6 will be updated
—> Package libssh2.x86_64 0:1.4.2-1.el6_6.1 will be an update
—> Package libstdc++.x86_64 0:4.4.7-3.el6 will be updated
—> Package libstdc++.x86_64 0:4.4.7-11.el6 will be an update
—> Package libstdc++-devel.x86_64 0:4.4.7-3.el6 will be updated
—> Package libstdc++-devel.x86_64 0:4.4.7-11.el6 will be an update
—> Package libtasn1.x86_64 0:2.3-3.el6_2.1 will be updated
—> Package libtasn1.x86_64 0:2.3-6.el6_5 will be an update
—> Package libtiff.x86_64 0:3.9.4-9.el6_3 will be updated
—> Package libtiff.x86_64 0:3.9.4-10.el6_5 will be an update
—> Package libudev.x86_64 0:147-2.46.el6 will be updated
—> Package libudev.x86_64 0:147-2.57.el6 will be an update
—> Package libuuid.x86_64 0:2.17.2-12.9.el6_4.3 will be updated
—> Package libuuid.x86_64 0:2.17.2-12.18.el6 will be an update
—> Package libuuid-devel.x86_64 0:2.17.2-12.9.el6_4.3 will be updated
—> Package libuuid-devel.x86_64 0:2.17.2-12.18.el6 will be an update
—> Package libxcb.x86_64 0:1.8.1-1.el6 will be updated
—> Package libxcb.x86_64 0:1.9.1-2.el6 will be an update
—> Package libxml2.x86_64 0:2.7.6-12.el6_4.1 will be updated
—> Package libxml2.x86_64 0:2.7.6-17.el6_6.1 will be an update
—> Package logrotate.x86_64 0:3.7.8-16.el6 will be updated
—> Package logrotate.x86_64 0:3.7.8-17.el6 will be an update
—> Package lvm2.x86_64 0:2.02.98-9.el6 will be updated
—> Package lvm2.x86_64 0:2.02.111-2.el6_6.3 will be an update
—> Package lvm2-libs.x86_64 0:2.02.98-9.el6 will be updated
—> Package lvm2-libs.x86_64 0:2.02.111-2.el6_6.3 will be an update
—> Package mailx.x86_64 0:12.4-6.el6 will be updated
—> Package mailx.x86_64 0:12.4-8.el6_6 will be an update
—> Package memcached.x86_64 0:1.4.15-2.el6.remi will be updated
—> Package memcached.x86_64 0:1.4.22-1.el6.remi will be an update
—> Package mod_ssl.x86_64 1:2.2.15-28.el6.centos will be updated
—> Package mod_ssl.x86_64 1:2.2.15-39.el6.centos will be an update
—> Package module-init-tools.x86_64 0:3.9-21.el6_4 will be updated
—> Package module-init-tools.x86_64 0:3.9-24.el6 will be an update
—> Package mongo-10gen.x86_64 0:2.4.5-mongodb_1 will be obsoleted
—> Package mongo-10gen-server.x86_64 0:2.4.5-mongodb_1 will be obsoleted
—> Package mongodb-org.x86_64 0:2.6.10-1 will be obsoleting
–> Processing Dependency: mongodb-org-tools = 2.6.10 for package: mongodb-org-2.6.10-1.x86_64
–> Processing Dependency: mongodb-org-shell = 2.6.10 for package: mongodb-org-2.6.10-1.x86_64
–> Processing Dependency: mongodb-org-mongos = 2.6.10 for package: mongodb-org-2.6.10-1.x86_64
—> Package mongodb-org-server.x86_64 0:2.6.10-1 will be obsoleting
—> Package mysql.x86_64 0:5.5.32-1.el6.remi will be updated
—> Package mysql.x86_64 0:5.5.44-1.el6.remi will be an update
—> Package mysql-devel.x86_64 0:5.5.32-1.el6.remi will be updated
—> Package mysql-devel.x86_64 0:5.5.44-1.el6.remi will be an update
—> Package mysql-libs.x86_64 0:5.5.32-1.el6.remi will be updated
—> Package mysql-libs.x86_64 0:5.5.44-1.el6.remi will be an update
—> Package mysql-server.x86_64 0:5.5.32-1.el6.remi will be updated
—> Package mysql-server.x86_64 0:5.5.44-1.el6.remi will be an update
—> Package nagios-common.x86_64 0:3.5.0-1.el6 will be updated
—> Package nagios-common.x86_64 0:3.5.1-1.el6 will be an update
—> Package nagios-plugins.x86_64 0:1.4.16-5.el6 will be updated
—> Package nagios-plugins.x86_64 0:1.4.16-10.el6 will be an update
—> Package nagios-plugins-disk.x86_64 0:1.4.16-5.el6 will be updated
—> Package nagios-plugins-disk.x86_64 0:1.4.16-10.el6 will be an update
—> Package nagios-plugins-http.x86_64 0:1.4.16-5.el6 will be updated
—> Package nagios-plugins-http.x86_64 0:1.4.16-10.el6 will be an update
—> Package nagios-plugins-load.x86_64 0:1.4.16-5.el6 will be updated
—> Package nagios-plugins-load.x86_64 0:1.4.16-10.el6 will be an update
—> Package nagios-plugins-nrpe.x86_64 0:2.14-3.el6 will be updated
—> Package nagios-plugins-nrpe.x86_64 0:2.15-2.el6 will be an update
—> Package nagios-plugins-ssh.x86_64 0:1.4.16-5.el6 will be updated
—> Package nagios-plugins-ssh.x86_64 0:1.4.16-10.el6 will be an update
—> Package ncdu.x86_64 0:1.7-1.el6 will be updated
—> Package ncdu.x86_64 0:1.11-1.el6 will be an update
—> Package neon.x86_64 0:0.29.3-2.el6 will be updated
—> Package neon.x86_64 0:0.29.3-3.el6_4 will be an update
—> Package openldap.x86_64 0:2.4.23-32.el6_4.1 will be updated
—> Package openldap.x86_64 0:2.4.39-8.el6 will be an update
—> Package openssh.x86_64 0:5.3p1-84.1.el6 will be updated
—> Package openssh.x86_64 0:5.3p1-104.el6_6.1 will be an update
—> Package openssh-clients.x86_64 0:5.3p1-84.1.el6 will be updated
—> Package openssh-clients.x86_64 0:5.3p1-104.el6_6.1 will be an update
—> Package openssh-server.x86_64 0:5.3p1-84.1.el6 will be updated
—> Package openssh-server.x86_64 0:5.3p1-104.el6_6.1 will be an update
—> Package openssl.x86_64 0:1.0.1e-16.el6_5.14 will be updated
—> Package openssl.x86_64 0:1.0.1e-30.el6.11 will be an update
—> Package openssl-devel.x86_64 0:1.0.1e-16.el6_5.14 will be updated
—> Package openssl-devel.x86_64 0:1.0.1e-30.el6.11 will be an update
—> Package pam.x86_64 0:1.1.1-13.el6 will be updated
—> Package pam.x86_64 0:1.1.1-20.el6 will be an update
—> Package pango.x86_64 0:1.28.1-7.el6_3 will be updated
—> Package pango.x86_64 0:1.28.1-10.el6 will be an update
—> Package pciutils-libs.x86_64 0:3.1.10-2.el6 will be updated
—> Package pciutils-libs.x86_64 0:3.1.10-4.el6 will be an update
—> Package perl.x86_64 4:5.10.1-131.el6_4 will be updated
—> Package perl.x86_64 4:5.10.1-136.el6_6.1 will be an update
—> Package perl-Compress-Raw-Zlib.x86_64 1:2.020-131.el6_4 will be updated
—> Package perl-Compress-Raw-Zlib.x86_64 1:2.021-136.el6_6.1 will be an update
—> Package perl-Compress-Zlib.x86_64 0:2.020-131.el6_4 will be updated
—> Package perl-Compress-Zlib.x86_64 0:2.021-136.el6_6.1 will be an update
—> Package perl-IO-Compress-Base.x86_64 0:2.020-131.el6_4 will be updated
—> Package perl-IO-Compress-Base.x86_64 0:2.021-136.el6_6.1 will be an update
—> Package perl-IO-Compress-Zlib.x86_64 0:2.020-131.el6_4 will be updated
—> Package perl-IO-Compress-Zlib.x86_64 0:2.021-136.el6_6.1 will be an update
—> Package perl-Module-Pluggable.x86_64 1:3.90-131.el6_4 will be updated
—> Package perl-Module-Pluggable.x86_64 1:3.90-136.el6_6.1 will be an update
—> Package perl-Pod-Escapes.x86_64 1:1.04-131.el6_4 will be updated
—> Package perl-Pod-Escapes.x86_64 1:1.04-136.el6_6.1 will be an update
—> Package perl-Pod-Simple.x86_64 1:3.13-131.el6_4 will be updated
—> Package perl-Pod-Simple.x86_64 1:3.13-136.el6_6.1 will be an update
—> Package perl-libs.x86_64 4:5.10.1-131.el6_4 will be updated
—> Package perl-libs.x86_64 4:5.10.1-136.el6_6.1 will be an update
—> Package perl-version.x86_64 3:0.77-131.el6_4 will be updated
—> Package perl-version.x86_64 3:0.77-136.el6_6.1 will be an update
—> Package php.x86_64 0:5.4.17-2.el6.remi will be updated
—> Package php.x86_64 0:5.4.42-1.el6.remi will be an update
—> Package php-cli.x86_64 0:5.4.17-2.el6.remi will be updated
—> Package php-cli.x86_64 0:5.4.42-1.el6.remi will be an update
—> Package php-common.x86_64 0:5.4.17-2.el6.remi will be updated
—> Package php-common.x86_64 0:5.4.42-1.el6.remi will be an update
—> Package php-devel.x86_64 0:5.4.17-2.el6.remi will be updated
—> Package php-devel.x86_64 0:5.4.42-1.el6.remi will be an update
—> Package php-gd.x86_64 0:5.4.17-2.el6.remi will be updated
—> Package php-gd.x86_64 0:5.4.42-1.el6.remi will be an update
—> Package php-mcrypt.x86_64 0:5.4.17-2.el6.remi will be updated
—> Package php-mcrypt.x86_64 0:5.4.42-1.el6.remi will be an update
—> Package php-mysql.x86_64 0:5.4.17-2.el6.remi will be updated
—> Package php-mysql.x86_64 0:5.4.42-1.el6.remi will be an update
—> Package php-pdo.x86_64 0:5.4.17-2.el6.remi will be updated
—> Package php-pdo.x86_64 0:5.4.42-1.el6.remi will be an update
—> Package php-pear.noarch 1:1.9.4-12.el6.remi.1 will be updated
—> Package php-pear.noarch 1:1.9.5-10.el6.remi will be an update
–> Processing Dependency: php-xml for package: 1:php-pear-1.9.5-10.el6.remi.noarch
–> Processing Dependency: php-posix for package: 1:php-pear-1.9.5-10.el6.remi.noarch
—> Package php-pecl-gearman.x86_64 0:0.8.3-1.el6.remi.1 will be updated
—> Package php-pecl-gearman.x86_64 0:1.1.2-2.el6.remi.5.4 will be an update
—> Package php-pecl-mongo.x86_64 0:1.4.1-1.el6.remi will be updated
—> Package php-pecl-mongo.x86_64 0:1.6.9-1.el6.remi.5.4 will be an update
—> Package php-pgsql.x86_64 0:5.4.17-2.el6.remi will be updated
—> Package php-pgsql.x86_64 0:5.4.42-1.el6.remi will be an update
—> Package php-soap.x86_64 0:5.4.17-2.el6.remi will be updated
—> Package php-soap.x86_64 0:5.4.42-1.el6.remi will be an update
—> Package php-xmlrpc.x86_64 0:5.4.17-2.el6.remi will be updated
—> Package php-xmlrpc.x86_64 0:5.4.42-1.el6.remi will be an update
—> Package pixman.x86_64 0:0.26.2-5.el6_4 will be updated
—> Package pixman.x86_64 0:0.32.4-4.el6 will be an update
—> Package plymouth.x86_64 0:0.8.3-27.el6.centos will be updated
—> Package plymouth.x86_64 0:0.8.3-27.el6.centos.1 will be an update
—> Package plymouth-core-libs.x86_64 0:0.8.3-27.el6.centos will be updated
—> Package plymouth-core-libs.x86_64 0:0.8.3-27.el6.centos.1 will be an update
—> Package plymouth-scripts.x86_64 0:0.8.3-27.el6.centos will be updated
—> Package plymouth-scripts.x86_64 0:0.8.3-27.el6.centos.1 will be an update
—> Package policycoreutils.x86_64 0:2.0.83-19.30.el6 will be updated
—> Package policycoreutils.x86_64 0:2.0.83-19.47.el6_6.1 will be an update
—> Package polkit.x86_64 0:0.96-2.el6_0.1 will be updated
—> Package polkit.x86_64 0:0.96-7.el6 will be an update
—> Package postfix.x86_64 2:2.6.6-2.2.el6_1 will be updated
—> Package postfix.x86_64 2:2.6.6-6.el6_5 will be an update
—> Package postgresql93.x86_64 0:9.3.2-1PGDG.rhel6 will be updated
—> Package postgresql93.x86_64 0:9.3.9-1PGDG.rhel6 will be an update
—> Package postgresql93-contrib.x86_64 0:9.3.2-1PGDG.rhel6 will be updated
—> Package postgresql93-contrib.x86_64 0:9.3.9-1PGDG.rhel6 will be an update
—> Package postgresql93-devel.x86_64 0:9.3.2-1PGDG.rhel6 will be updated
—> Package postgresql93-devel.x86_64 0:9.3.9-1PGDG.rhel6 will be an update
—> Package postgresql93-libs.x86_64 0:9.3.2-1PGDG.rhel6 will be updated
—> Package postgresql93-libs.x86_64 0:9.3.9-1PGDG.rhel6 will be an update
—> Package postgresql93-server.x86_64 0:9.3.2-1PGDG.rhel6 will be updated
—> Package postgresql93-server.x86_64 0:9.3.9-1PGDG.rhel6 will be an update
—> Package prelink.x86_64 0:0.4.6-3.el6 will be updated
—> Package prelink.x86_64 0:0.4.6-3.1.el6_4 will be an update
—> Package procps.x86_64 0:3.2.8-25.el6 will be updated
—> Package procps.x86_64 0:3.2.8-30.el6 will be an update
—> Package psmisc.x86_64 0:22.6-15.el6_0.1 will be updated
—> Package psmisc.x86_64 0:22.6-19.el6_5 will be an update
—> Package python.x86_64 0:2.6.6-37.el6_4 will be updated
—> Package python.x86_64 0:2.6.6-52.el6 will be an update
—> Package python-devel.x86_64 0:2.6.6-37.el6_4 will be updated
—> Package python-devel.x86_64 0:2.6.6-52.el6 will be an update
—> Package python-libs.x86_64 0:2.6.6-37.el6_4 will be updated
—> Package python-libs.x86_64 0:2.6.6-52.el6 will be an update
—> Package python-urlgrabber.noarch 0:3.9.1-8.el6 will be updated
—> Package python-urlgrabber.noarch 0:3.9.1-9.el6 will be an update
—> Package ql2400-firmware.noarch 0:5.08.00-1.el6 will be updated
—> Package ql2400-firmware.noarch 0:7.03.00-1.el6_5 will be an update
—> Package ql2500-firmware.noarch 0:5.08.00-1.el6 will be updated
—> Package ql2500-firmware.noarch 0:7.03.00-1.el6_5 will be an update
—> Package redhat-rpm-config.noarch 0:9.0.3-42.el6 will be updated
—> Package redhat-rpm-config.noarch 0:9.0.3-42.el6.centos will be an update
—> Package remi-release.noarch 0:6-2.el6.remi will be updated
—> Package remi-release.noarch 0:6.5-1.el6.remi will be an update
—> Package rkhunter.noarch 0:1.4.0-2.el6 will be updated
—> Package rkhunter.noarch 0:1.4.2-4.el6 will be an update
—> Package rpm.x86_64 0:4.8.0-32.el6 will be updated
—> Package rpm.x86_64 0:4.8.0-38.el6_6 will be an update
—> Package rpm-build.x86_64 0:4.8.0-32.el6 will be updated
—> Package rpm-build.x86_64 0:4.8.0-38.el6_6 will be an update
—> Package rpm-libs.x86_64 0:4.8.0-32.el6 will be updated
—> Package rpm-libs.x86_64 0:4.8.0-38.el6_6 will be an update
—> Package rpm-python.x86_64 0:4.8.0-32.el6 will be updated
—> Package rpm-python.x86_64 0:4.8.0-38.el6_6 will be an update
—> Package rsync.x86_64 0:3.0.6-9.el6 will be updated
—> Package rsync.x86_64 0:3.0.6-12.el6 will be an update
—> Package rsyslog.x86_64 0:5.8.10-6.el6 will be updated
—> Package rsyslog.x86_64 0:5.8.10-10.el6_6 will be an update
—> Package selinux-policy.noarch 0:3.7.19-195.el6_4.12 will be updated
—> Package selinux-policy.noarch 0:3.7.19-260.el6_6.5 will be an update
—> Package selinux-policy-targeted.noarch 0:3.7.19-195.el6_4.12 will be updated
—> Package selinux-policy-targeted.noarch 0:3.7.19-260.el6_6.5 will be an update
—> Package setup.noarch 0:2.8.14-20.el6 will be updated
—> Package setup.noarch 0:2.8.14-20.el6_4.1 will be an update
—> Package setuptool.x86_64 0:1.19.9-3.el6 will be updated
—> Package setuptool.x86_64 0:1.19.9-4.el6 will be an update
—> Package sgml-common.noarch 0:0.6.3-32.el6 will be updated
—> Package sgml-common.noarch 0:0.6.3-33.el6 will be an update
—> Package shadow-utils.x86_64 2:4.1.4.2-13.el6 will be updated
—> Package shadow-utils.x86_64 2:4.1.4.2-19.el6_6.1 will be an update
—> Package strace.x86_64 0:4.5.19-1.17.el6 will be updated
—> Package strace.x86_64 0:4.5.19-1.19.el6 will be an update
—> Package subversion.x86_64 0:1.6.11-9.el6_4 will be updated
—> Package subversion.x86_64 0:1.6.11-12.el6_6 will be an update
—> Package sudo.x86_64 0:1.8.6p3-7.el6 will be updated
—> Package sudo.x86_64 0:1.8.6p3-15.el6 will be an update
—> Package system-config-firewall-base.noarch 0:1.2.27-5.el6 will be updated
—> Package system-config-firewall-base.noarch 0:1.2.27-7.2.el6_6 will be an update
—> Package system-config-firewall-tui.noarch 0:1.2.27-5.el6 will be updated
—> Package system-config-firewall-tui.noarch 0:1.2.27-7.2.el6_6 will be an update
—> Package systemtap.x86_64 0:1.8-7.el6 will be updated
—> Package systemtap.x86_64 0:2.5-5.el6 will be an update
—> Package systemtap-client.x86_64 0:1.8-7.el6 will be updated
—> Package systemtap-client.x86_64 0:2.5-5.el6 will be an update
—> Package systemtap-devel.x86_64 0:1.8-7.el6 will be updated
—> Package systemtap-devel.x86_64 0:2.5-5.el6 will be an update
—> Package systemtap-runtime.x86_64 0:1.8-7.el6 will be updated
—> Package systemtap-runtime.x86_64 0:2.5-5.el6 will be an update
—> Package sysvinit-tools.x86_64 0:2.87-4.dsf.el6 will be updated
—> Package sysvinit-tools.x86_64 0:2.87-5.dsf.el6 will be an update
—> Package telnet.x86_64 1:0.17-47.el6_3.1 will be updated
—> Package telnet.x86_64 1:0.17-48.el6 will be an update
—> Package tmux.x86_64 0:1.6-1.el6.rf will be updated
—> Package tmux.x86_64 0:1.6-3.el6 will be an update
—> Package tzdata.noarch 0:2013c-2.el6 will be updated
—> Package tzdata.noarch 0:2015e-1.el6 will be an update
—> Package udev.x86_64 0:147-2.46.el6 will be updated
—> Package udev.x86_64 0:147-2.57.el6 will be an update
—> Package unzip.x86_64 0:6.0-1.el6 will be updated
—> Package unzip.x86_64 0:6.0-2.el6_6 will be an update
—> Package upstart.x86_64 0:0.6.5-12.el6_4.1 will be updated
—> Package upstart.x86_64 0:0.6.5-13.el6_5.3 will be an update
—> Package util-linux-ng.x86_64 0:2.17.2-12.9.el6_4.3 will be updated
—> Package util-linux-ng.x86_64 0:2.17.2-12.18.el6 will be an update
—> Package wget.x86_64 0:1.12-1.8.el6 will be updated
—> Package wget.x86_64 0:1.12-5.el6_6.1 will be an update
—> Package xcb-util.x86_64 0:0.3.6-1.el6 will be updated
—> Package xcb-util.x86_64 0:0.3.6-5.el6 will be an update
—> Package xml-common.noarch 0:0.6.3-32.el6 will be updated
—> Package xml-common.noarch 0:0.6.3-33.el6 will be an update
—> Package xorg-x11-drv-ati-firmware.noarch 0:6.99.99-1.el6 will be updated
—> Package xorg-x11-drv-ati-firmware.noarch 0:7.3.99-2.el6 will be an update
—> Package xz.x86_64 0:4.999.9-0.3.beta.20091007git.el6 will be updated
—> Package xz.x86_64 0:4.999.9-0.5.beta.20091007git.el6 will be an update
—> Package xz-libs.x86_64 0:4.999.9-0.3.beta.20091007git.el6 will be updated
—> Package xz-libs.x86_64 0:4.999.9-0.5.beta.20091007git.el6 will be an update
—> Package xz-lzma-compat.x86_64 0:4.999.9-0.3.beta.20091007git.el6 will be updated
—> Package xz-lzma-compat.x86_64 0:4.999.9-0.5.beta.20091007git.el6 will be an update
—> Package yum.noarch 0:3.2.29-40.el6.centos will be updated
—> Package yum.noarch 0:3.2.29-60.el6.centos will be an update
—> Package yum-plugin-fastestmirror.noarch 0:1.1.30-14.el6 will be updated
—> Package yum-plugin-fastestmirror.noarch 0:1.1.30-30.el6 will be an update
—> Package zsh.x86_64 0:4.3.10-5.el6 will be updated
—> Package zsh.x86_64 0:4.3.10-9.el6 will be an update
–> Running transaction check
—> Package boost-math.x86_64 0:1.41.0-25.el6.centos will be installed
—> Package compat-libevent14.x86_64 0:1.4.13-1.rhel6 will be installed
—> Package gdk-pixbuf2.x86_64 0:2.24.1-5.el6 will be installed
—> Package libevent-devel.i686 0:1.4.13-4.el6 will be installed
–> Processing Dependency: libevent = 1.4.13-4.el6 for package: libevent-devel-1.4.13-4.el6.i686
–> Processing Dependency: libevent_extra-1.4.so.2 for package: libevent-devel-1.4.13-4.el6.i686
–> Processing Dependency: libevent_core-1.4.so.2 for package: libevent-devel-1.4.13-4.el6.i686
–> Processing Dependency: libevent-1.4.so.2 for package: libevent-devel-1.4.13-4.el6.i686
—> Package libevent-devel.x86_64 0:1.4.13-4.el6 will be updated
—> Package mongodb-org-mongos.x86_64 0:2.6.10-1 will be installed
—> Package mongodb-org-shell.x86_64 0:2.6.10-1 will be installed
—> Package mongodb-org-tools.x86_64 0:2.6.10-1 will be installed
—> Package php-process.x86_64 0:5.4.42-1.el6.remi will be installed
—> Package php-xml.x86_64 0:5.4.42-1.el6.remi will be installed
—> Package shared-mime-info.x86_64 0:0.70-6.el6 will be installed
—> Package tokyocabinet.x86_64 0:1.4.33-6.el6 will be installed
–> Running transaction check
—> Package libevent.i686 0:1.4.13-4.el6 will be installed
–> Processing Dependency: librt.so.1(GLIBC_2.2) for package: libevent-1.4.13-4.el6.i686
–> Processing Dependency: librt.so.1 for package: libevent-1.4.13-4.el6.i686
–> Processing Dependency: libresolv.so.2 for package: libevent-1.4.13-4.el6.i686
–> Processing Dependency: libnsl.so.1 for package: libevent-1.4.13-4.el6.i686
–> Processing Dependency: libc.so.6(GLIBC_2.4) for package: libevent-1.4.13-4.el6.i686
—> Package libevent.x86_64 0:1.4.13-4.el6 will be updated
—> Package libevent.x86_64 0:1.4.13-4.el6 will be updated
–> Running transaction check
—> Package glibc.i686 0:2.12-1.149.el6_6.9 will be installed
–> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.12-1.149.el6_6.9.i686
–> Processing Dependency: libfreebl3.so for package: glibc-2.12-1.149.el6_6.9.i686
–> Running transaction check
—> Package nss-softokn-freebl.i686 0:3.14.3-22.el6_6 will be installed
–> Finished Dependency Resolution
–> Running transaction check
—> Package kernel.x86_64 0:2.6.32-279.14.1.el6 will be erased
–> Finished Dependency Resolution
Error: Multilib version problems found. This often means that the root
cause is something else and multilib version checking is just
pointing out that there is a problem. Eg.:

1. You have an upgrade for libevent-devel which is missing some
dependency that another package requires. Yum is trying to
solve this by installing an older version of libevent-devel of the
different architecture. If you exclude the bad architecture
yum will tell you what the root cause is (which package
requires what). You can try redoing the upgrade with
–exclude libevent-devel.otherarch … this should give you an error
message showing the root cause of the problem.

2. You have multiple architectures of libevent-devel installed, but
yum can only see an upgrade for one of those arcitectures.
If you don’t want/need both architectures anymore then you
can remove the one with the missing update and everything
will work.

3. You have duplicate versions of libevent-devel installed already.
You can use “yum check” to get yum show these errors.

…you can also use –setopt=protected_multilib=false to remove
this checking, however this is almost never the correct thing to
do as something else is very likely to go wrong (often causing
much more problems).

Protected multilib versions: libevent-devel-2.0.19-1.rhel6.x86_64 != libevent-devel-1.4.13-4.el6.i686
Error: Protected multilib versions: libevent-1.4.13-4.el6.i686 != libevent-2.0.19-1.rhel6.x86_64
You could try using –skip-broken to work around the problem
You could try running: rpm -Va –nofiles –nodigest
[[email protected]~]#

 


  1. I hope I resolved it, it’s going into production in the morning

 

Categories: CentOS & RHEL 6 Tags:
  1. No comments yet.
  1. No trackbacks yet.